Firefox 66.0.4发布:修复用户无法使用扩展问题

by admin on 2020年2月29日

由于 Mozilla 公司忘记更新用于签署 Firefox
插件的安全证书,当证书过期,导致新的插件下载安装失败,并阻止现有的插件正常工作。

图片 1

图片 2

过去几天,大量用户报告Firefox不允许他们安装附加组件,现有的扩展也已被禁用。调查结果显示,错误与过期的证书有关。随后,Mozilla开始使用其研究系统推出一个修补程序,以启用一些开发模式下的用户出现的扩展失效问题,并允许安装新的附加组件。对于普通用户而言,Mozilla刚刚发布的最新版Firefox
66.0.4也许更有用,因为最重要的变化就是修复了扩展的中断错误。

Mozilla 现在宣布他们推出了一个修复程序,并表示:

在发行说明中,Mozilla已声明它已包含此修复程序,但少数附加组件可能仍会列为不受支持或未在更新后出现在addons页面中。但这应该并不是什么大问题,用户可以重新安装扩展并且数据不会丢失。

我们的团队已经确定并推出了针对 Release、Beta 和 Nightly 的所有 Firefox
浏览器桌面用户的修复程序。修复程序将在接下来的几个小时内自动应用于后台。不需要采取任何有效步骤来使插件再次起作用。

但是修复程序无法恢复多帐户容器,Facebook容器和其他使用容器功能的附加组件的数,您必须再次设置这些加载项并重新登录才能继续使用它们。

大多数用户不需要采取任何行动,但如果你已禁用 Studies,这是 Mozilla
用于对新功能进行 A/B 测试的功能,则需要重新启用它。

同样,安装此更新后可能无法自动重新启用主题,因此您可能需要再次从加载项页面重新启用它们。如果您使用加载项来自定义主页或搜索设置,则自定义值将重置为默认值,您可能需要在about:preferences或about:addons中再次自定义体验。

Firefox 用户可以通过访问以下内容来检查他们是否启用了 Studies:

Firefox 选项/首选项 – >隐私和安全 – >允许 Firefox 安装和运行
Studies(向下滚动以查找设置)

重新启用加载项后,可以再次禁用 Studies。

该修复程序正在逐步推出。要检查你是否有修复,可以在位置栏中输入“about:studies”。如果修复程序处于活动状态,你将看到“hotfix-update-xpi-signing-intermediate-bug-1548973”
或者 “hotfix-reset-xpi-verification-timestamp-1548973”。

Mozilla正在为未来的更新开发一个更加集成的修复程序,不需要使用 Studies。

稿源:ithome

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图